欢迎光临~京科智造(北京)科技有限公司-iJUNCO.com
语言选择: 中文版 ∷  英文版

基础知识

Android studio 中gradle版本和插件版本对应关系

最近打开android studio,页面提示gradle版本又有新的升级,于是习惯性的点了下更新,结果,打包的过程中控制台就报错了,错误如下:

Error:(16, 0) Minimum supported Gradle version is 4.4 Current version is 2.3.1

查看项目,发现gradle版本目录已经修改为4.4,


网上查阅资料,发现还得需要修改项目根目录下的build.gradle文件中,相应的gradle插件的版本号

dependencies { classpath'com.android.tools.build:gradle:2.3.1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files}

将原来gradle插件版本号修改为3.1.0之后,再点击同步按钮后,项目可以正常打包。

为此,专门总结一下gradle版本与相应插件版本的对应关系,下面是android官方的对应关系


这是Androi这是Android官方开发文档详细的说明地址官方开发文档详细的说明地址

https://developer.android.google.cn/studio/releases/gradle-plugin#updating-plugin

0人点赞

作者:黑狼_佩恩
链接:https://www.jianshu.com/p/6af934b325b2
来源:简书
著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

联系我们

联系人:徐经理

手机:17807330718

电话:010-64725858

邮箱:ijunco@163.com

地址: 北京市门头沟区曹各庄路34号院1号楼3栋316室

关闭
用手机扫描二维码关闭
二维码